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Adding Text to Documents
You can add text to documents using two different types of tools:

• Annotations, such as text boxes and balloons.

• Labels, such as text labels and Smart Labels.
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Annotations
An essential part of the drawing process is adding text, notes, and annotations.
Annotations are text and graphics that give information about a drawing. You can
add this information quickly and easily with the text and annotation commands in
the software.

To place annotations in a document, you can click one of the following buttons:

• Text Box button on the Draw toolbar

 

• Balloon button on the Dimension toolbar

Annotations with Leaders
When you create a balloon, you can place it with a leader by setting options on the
ribbon bar. The leader can point to another element or be placed in free space.
Annotations with leaders have the following components:

 

(A) Leader line

(B) Break line

(C) Terminator

(D) Annotation
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You can manipulate the annotation by selecting the leader and moving parts of it.
You can control the display of a leader break line and terminator and insert or
delete vertices on a leader.

Adding Leaders
You can add a leader to an annotation with the Leader command. An annotation
can have more than one leader. The terminator end of the annotation can point to an
element or be placed in free space. The annotation end of a new leader must
connect to an annotation or the leader on an annotation.

 

You can create a callout by placing a text box and adding a leader to it with the
Leader command.

Annotations and Associations
Annotations can be associative or non-associative. An associative annotation moves
when its associated element moves. Text boxes differ from the other annotations in
that they are always non-associative.

If you attach the terminator of a leader to an element, the annotation moves with the
element.
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If you point the terminator of a leader to free space, the annotation is not associative
to any element in the drawing. To make an annotation associative, you can select
the terminator of the leader and drag it to an element.

Formatting Annotations
You can format an annotation several ways. If you want several annotations to look
the same, you can apply a style by selecting it on the ribbon bar. You can apply
dimension styles to balloons, but not text boxes. You can apply text styles to text
boxes.

Tip  If you want to format an existing balloon, you must click the balloon leader to
select the balloon. Then, you can change the formats of the balloon.

If you want annotations to look unique, you can select an annotation and edit its
properties with the ribbon bar or the Properties command on the Edit menu.
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Engineering Fonts
The engineering fonts delivered with the software contain industry-specific fonts,
special characters, and symbols that you can use to annotate engineering drawings.
These fonts include degree symbols, diameter symbols, and other special
characters and symbols that are not usually included in a typical word processing
package.

Your choice of font should be based on the industry for which you are creating
engineering drawings.

The software provides TrueType® fonts; with TrueType fonts, what you see on the
screen is what appears on the printed page. The screen display of the document
closely matches the printed document.

When you open a .DWG or .DGN document, the software provides a default
mapping to determine which TrueType font will be assigned to which AutoCAD or
MicroStation font. You can make changes to this mapping to define your own
mapping. You can change the mapping with the Options command on the Tools
menu. On the Foreign Data tab, you can click the appropriate Options button.
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Labels
Technical drawings often have many labels that display important information
about the objects or elements in the document. There are two types of labels: text
labels and Smart Labels.

Text labels are associated with an element or object. If you move the element or
object, the text label moves with it. You can create text labels in a document by
double-clicking an element or object. A text label appears near the element so that
you can type text. The default position of the label is bottom center on all elements,
except for closed elements, such as a circle or rectangle. The default position on
closed elements is the center of the element. When you enter the text that you want,
the text label orients itself with the element.

Another kind of label, a Smart Label, can be associated to an object or element’s
text attributes. A Smart Label is often distinguished by a question mark in the
display.

 

A Smart Label displays the attributes of the element or object as text in the
document. You can drag Smart Labels from the Symbol Explorer into the current
document. Smart Labels have an .sym extension. As you change an element’s or
object’s attributes in the Attribute Viewer or the Properties dialog box, the Smart
Label’s text displays those changes.

 

 

If an element or object has no attributes, and you drag a Smart Label to it, the
element or object picks up the attributes of the Smart Label. For example, you
might want to assign attributes to a valve, such as pressure and material type. If the
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Smart Label has the pressure and material type defined, and the valve does not, the
Smart Label’s pressure and material type are copied to the valve.

If an element already has values assigned to its attributes, a Smart Label placed on
the element displays the values that are already assigned to the element. The values
for the Smart Label are erased. For example, if the valve already has values for
pressure and material type attributes, the values of those attributes override any
values for a Smart Label placed on the valve.

A Smart Label can contain graphics, such as a circle, ellipse, parametric symbol,
and so forth.

Tip  Not all Smart Labels assume the text attributes of an element or object. Some
Smart Labels contain shapes that grow automatically if you add text to the Smart
Label.
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 Procedures to Explore in On-line Help
• Place a Text Box

• Place a Balloon

• Format a Text Box

• Format a Dimension or Annotation

• Add a Leader

• Place a Smart Label

• Create a Text Label
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Formatting Overview
The software provides several different methods for formatting one or more
geometric elements, such as lines, arcs, and circles. You can also format
dimensions, annotations, and fills.

Styles
To make elements that are the same type look alike, you can use styles to apply
several formats at once. Styles are a collection of formats that are saved under a
name. Styles allow you to save several formats so you can use them again and
again. Using styles guarantees consistency in a drawing.

To make an element look unique, you can select it and then format it directly.
Formatting a few elements at a time takes more time than applying styles, but gives
you greater flexibility.

The software provides fills that you can apply to closed boundaries. A fill floods a
closed boundary with a solid color or pattern.

Besides fills, the software provides line types such as continuous, dash, chain,
continuous chain, double chain, dot, and end gap. New line types can be created
through Visual Basic automation.

The software provides several other tools for consistent drawings. You can save
styles and background sheets in a template so that you can use them in other
drawings.

Properties and Parameters
You can edit the properties of an element, symbol, or object by selecting it and then
changing properties on the ribbon bar. You can also right click and select the
Properties command on the shortcut menu.

A property unique characteristic of an element, object, symbol, or document. You
can display document properties in the Windows Explorer or by clicking Properties
on the File menu or Edit menu.

Properties for elements or objects have three different types, as defined on the
Properties dialog box:

• Style properties, as specified on the Format tab. Style properties affect the
format of the element.

• Size properties, as specified on the Info. Size properties affect characteristics of
the element, such as the length.
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• User-defined properties, as created on the User tab. User-defined properties
are usually in the form of a text notation, such as cost, manufacturer, and so
forth You can change user-defined properties, but these changes have no affect
on the appearance of the element or object.

For example, a valve symbol’s style properties can include color, line style, and
width. Other user-defined properties stored with the symbol can include the
manufacturer, cost, or material. User-defined properties are displayed in the
Attribute Viewer when you select the valve symbol.
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Applying Unique Formats
At times, you may want to make geometric elements, dimensions, fills, or
annotations look different from other ones on the drawing. To do this, you can edit
the formats of the element directly. When you do this, the formats are applied only
to the selected element or the one you are about to draw. This overrides whatever
settings are applied to it by the style, without changing the style.

Formatting Individual Elements
Before you place or draw an element, you can set unique formats with the ribbon
bar, without changing the style. The commands on the Format menu, except for the
Style command, can also be used to set an element’s formats before you place or
draw it.

For example, if you click the Text Box command, a style appears in the Style box
on the ribbon bar. The style contains a format for bold fonts. If you turn off the
Bold option on the ribbon bar, the text box that you place will not display bold text.

You can also apply unique formats to an existing element, dimension, fill, or
annotation. You can select the element and then edit the formats with the ribbon
bar or the Properties command on the Edit menu.

For example, if you select a text box that has a style that displays borders, you can
remove the borders with the Properties command on the Edit menu. Since you are
changing the element’s format, and not its style, the style of the text box still
contains borders. If you apply this style to any other text box, it will still display
borders.

Formatting More Than One Element
You can change the format of more than one element at a time by selecting the
elements and formatting them the same way you would format an individual
element. However, all the elements that you select must be of the same type. For
example, if you select several text boxes, you can apply settings to all of them at
once. You cannot apply the same settings to a dimension and a text box by
selecting both of them at once.
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Applying Formats with Styles
If you want elements that are the same type to look alike, you should use styles, a
collection of formats that can be applied to the following items:

• Geometric elements

• Dimensions

• Annotations

• Fills

Using styles ensures consistency. If you place or draw one or more elements, the
formats in the style are applied directly to the elements. You do not have to spend
time formatting as you draw. You can apply the formats in each style again and
again.

The software provides styles that you can apply to elements so that they conform to
an engineering standard, such as ISO or ANSI.

Managing Styles
Using the Style command on the Format menu, you can create several styles so that
elements in a drawing appear the way you want. You can use or modify the styles
delivered with the software, or you can set up new ones that conform to your
unique requirements. One or more styles can be stored in a template so that you
can use them in other drawings.

The software divides styles into types, such as text, dimension, line, and fill. A style
type contains one or more styles. You can create styles for each style type.

When you create a new document based on a template, the template is copied. The
copy includes any styles that are in the template. Fonts are never copied into a
document. If you want someone to view the fonts, and that person’s system does
not have the same fonts installed, you should give that person the fonts along with
the document.

Including Styles from Other Documents in a
Template
If you want to make styles from other documents available in the current document,
you can reference the styles with style resource documents. You can reference a
style resource document from the active template or document by clicking the
Resources button on the Styles dialog box. The Style Resources dialog box allows



Chapter 14 SmartSketch Getting Started Guide

214

you to add style resource documents to the current template or document. Style
resource documents can be any .IGR document or .RSC line style file that contains
styles native to that document.

If you create a document based on a template, any style resource documents
attached to the template are attached to the new document as well. When you
reference a style resource document from the current document or template, the
styles in the resource document are added to the Style dropdown list on the active
document’s ribbon bar. When you apply one of the line, dimension, or fill styles to
an element on the drawing sheet, the style is copied from the style resource
document to the current document. The fonts are added to the dropdown list on the
ribbon bar as well, but are not copied into the current document.

Applying Styles
The style type determines what type of item to which you can apply a style. A text
style can be applied to text within a text box. A fill style can be applied to a fill. A
line style can be applied to any geometric element such as a line, arc, circle, or
ellipse. A dimension style can be applied to a dimension or balloon.

When you place dimensions or annotations, or draw elements, the formats from
their default styles are applied automatically. For example, if you click
SmartDimension on the Dimension toolbar, the ANSI style appears on the ribbon
bar. Each dimension that you place receives the ANSI style. To apply a different
style, you can change the style name on the ribbon bar before or after you draw or
place an element.

Applying Styles to More Than One Element
Selecting more than one element and then applying the same style to them removes
any previous formats—the elements now all have the same formats from the style
that you applied. To do this, you must select elements that are in the same style
type, such as text, dimension, fill, or line. For example, you cannot apply a line
style to a dimension.
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you could update the drawing by editing the SmartSketch drawing. Each report
would automatically display the results of the drawing updates.

If the document’s size is not an important factor, then you might want to use
embedding. Embedded objects make the file size larger. Embedding is useful when
the person viewing the document with the information does not have access to the
software that created the information. The person can still view the information if it
is embedded in the document. For example, if you wanted to send out several
drawings for review, you could embed each SmartSketch drawing into a Word
document and mail the Word document to each reviewer.

Embedded information is also a good choice if the information does not need
updating frequently. If you want to embed an object or edit an embedded object,
you must have access to the software that created it.
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Working with Raster Images
Images created by lines of pixels are called raster images, and the code that
represents the pixels in the raster image is called raster data. The format of the
raster data in the document determines how the pixels are arranged when the image
is displayed. You can edit raster data

Differences Between Raster Data and Vector Data
Raster data is unintelligent. A line segment in a raster image cannot be manipulated
as a line segment. Rather, it must be manipulated as the collection of pixels that
form the line segment.

A vector data document is a collection of coherent, geometric elements. Vector
data is intelligent. A line segment in a vector file can be manipulated as a line
segment.

A vector data object is an indivisible entity. A raster image, by contrast, is
composed of pixels, arranged to give the appearance of lines, shapes, and
characters. When zoomed out, a raster image appears as contiguous lines and
shapes. However, if you zoom in, it becomes apparent that a raster image consists
of individual foreground pixels, represented as small squares on the screen.

Displaying Raster Images
ImageScape™ LT allows you to display and manipulate raster images along with
the vector data on the drawing sheet. When you save the current document, which
contains vector graphics, you can save a link to a raster image along with it.

This structure can be useful in many ways. For example, if a shopping center is
planned for a piece of property, and proposals are sought for the design of the
shopping center, an aerial photograph may be taken of the property. The
photograph can then be converted into a raster image. Proposals can be submitted
as vector documents that each contain a link to the original raster image. In this
way, different proposals for the shopping center can be easily evaluated, with each
proposal starting from the same raster image of the property.

Inserting an Image
To insert a raster image, you must first install ImageScape LT with the Add-Ins
command on the Tools menu. If you do not see the add-in listed in the Add-In
Manager, you must run Setup again and select the Custom installation. You can
then select an option for the add-in.
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After installing ImageScape LT, you can then insert the raster image with the
Image command on the Insert menu. You can only link the image; you cannot
embed it. To edit various properties of the image border, you can select the image
and click the Properties command on the shortcut menu.

Use the Position command to move, scale, rotate, and skew a source image to
match a target image or vector frame. All alignment modifications are made by
placing up to three source points and three target points. You can define source
points by clicking and dragging or by a single click on the source image.

Expanding the Raster Capabilities
You can expand the capabilities of the software with another Intergraph product
called ImageScape™. ImageScape allows efficient and productive use of scanned
drawings, aerial photographs, and rendered images. With ImageScape, you can do
the following:

• Clean up and modify scanned drawings, maps, and images.

• Revise old scanned drawings with powerful drawing tools in the software.

• Display raster or vector data transparently over an image backdrop.

• Place images in a precise position.

• Warp images or scanned drawings to correct for geometric distortions in the
original image.

• Produce and print hybrid raster or vector drawings for more effective
presentations and proposals.
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 Procedures to Explore in On-line Help
• Embed an Object

• Link an Object

• Insert a Raster Image
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Using the Internet and Intranet
SmartSketch is an excellent tool for publishing on the Internet. While you work on
a document in the software, you can access the Internet and Intranet, which allows
you to share design information within and across organizational boundaries.

Viewing the Web
You can view the World Wide Web from within SmartSketch with a special tool
called the Symbol Explorer. The Symbol Explorer is available only if you have
installed Internet Explorer 3.0 or later. After you click the Symbol Explorer button
on the Main toolbar, the Symbol Explorer appears on the right of document
window. You can type the URL or directory path of an HTML page in the Address
Box and press Enter to view the HTML page.

Publishing on the Web
SmartSketch is an ActiveX® document. This feature means that you can open a
SmartSketch document with its own toolbars and menus in the Internet Explorer
window, without having to activate SmartSketch. SmartSketch toolbars and menus
combine with those of the Internet Explorer, allowing you to work on the document
from the Web viewer. This practice can be convenient if you want to work on a
SmartSketch document and then go back to the HTML page that you were
viewing. Web administrators can use existing SmartSketch documents on the
intranet without having to convert them to another format for viewing on the Web.

Tip  You can also view ActiveX documents in Netscape™ Navigator if you install
the appropriate plug-in software. For more information, you should visit
www.netscape.com on the World Wide Web.

If you want to place a graphic document in an HTML page for viewing on the
Web, you can save the document to .cgm format.

Accessing the Internet Without Leaving
SmartSketch
If you want to access the Internet, you must first be connected to the Internet with a
modem. Then, you can access the Internet without leaving SmartSketch by clicking
the SmartSketch on the Web command on the Help menu.

Tip  The SmartSketch on the Web command displays in your system default web
browser. If you do not have a web browser, you can install Internet Explorer,



 The Internet and Intranet Chapter 16

235

which is delivered with SmartSketch. SmartSketch on the Web works with any
web browser, but you do get extra settings and hot links by using Internet Explorer.

From the SmartSketch on the Web, you can access a myriad of tools to help you
use SmartSketch more efficiently, keep up-to-date on product happenings, view a
Web gallery of SmartSketch drawings, and contact Intergraph.

You can also access information from your computer or from the SmartSketch CD.
So, you do not have to connect to the Internet to use the SmartSketch on the Web.
Some of the types of information you can access locally are tutorials, gallery
documents, and a symbol library.

Publishing Customer Drawings on the SmartSketch
Web Gallery
The SmartSketch on the Web HTML page also has links to a Web Gallery that
displays a collection of customer drawings produced with SmartSketch. The Web
Gallery shows drawings from each industry: mechanical, civil, and architectural
engineering, utilities, and so forth.

You can submit your own drawings to the Web Gallery by following the
instructions on the Web Gallery HTML page. Just follow the links from the
SmartSketch on the Web page.
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Hyperlinks
You may want to link an element or object in a document to other documents, such
as a web page. The Hyperlink button on the Main toolbar is used to create, edit and
follow hyperlink addresses attached to objects in a document.

Tip  If you use the Save As command to save the document to a .CGM file, the
hyperlinks are retained during the translation process, creating a .CGM drawing
file that is ready for web publishing. You can also use the Save As Web Page(s)
command to do this.
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ActiveCGM®
If you want to place a SmartSketch document on an HTML page for viewing on
the Web, you can save the document to .CGM format. Computer Graphic Metafile
(CGM), a standard file format for vector and raster data, is an ideal format for
publishing 2D vector drawings on the Web. This format requires little storage
space, displays quickly in a web browser, and has the ability to zoom and display
more detail. CGM documents can also contain embedded hotspots, hyperlinks, and
database links, allowing you to access information outside the document instantly.

You can save a document as a .CGM graphic embedded in a web page with the
Save As Web Page command on the File menu. You can also save to .CGM with
the Save As command.

Definition of CGM
CGM supports the definition of graphic objects bound to non-graphic attributes.
The CGM file format is defined by ANSI/ISO 8632-1992 (American National
Standards Institute/International Standards Organization) and MIL-STD-2301
(Military Standard). CGM is the international standard that defines a hybrid (raster,
vector, and text) graphics format. Definition of graphical objects is supported at
any arbitrary level of abstraction through a tagging mechanism similar to SGML
and HTML.

Definition of ActiveCGM
ActiveCGM® technology converts 2D design files, such as construction drawings,
into CGM files to link non-graphical data into graphical elements.  For example,
you can navigate an intelli gent drawing using a Web browser. ActiveCGM
provides rapid, accurate, enterprise-wide access and display of graphic
information. It allows hyperlinking of vector and raster graphics defined in the
Version 4.0 Computer Graphics Metafile format. ActiveCGM products based on
ActiveCGM technology support zooming, panning, magnification, navigation of
CGM graphics.
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Procedures to Explore in On-line Help
• Access the SmartSketch World Wide Web Page

• Open a SmartSketch Document Inside the Internet Explorer

 



 C H A P T E R 17
 Customizing the Software

Customization......................................................................................... 240

Adding Additional Tools to the Software................................................ 244

Add-Ins Included with the Software........................................................ 245

Procedures to Explore in On-line Help.................................................. 246

 

 



Chapter 17 SmartSketch Getting Started Guide

240

Customization
Customization allows you to modify and enhance the software to meet your
specific needs. You can use your favorite standard Windows programming tools
and languages that are OLE-aware, such as Microsoft Visual Basic. There are
several ways to customize the software:

• You can add built-in commands or macros to the toolbars and menus in the
software.

• You can go a step further and create your own macros in Visual Basic or other
OLE-aware programming applications. Macros can automate a series of tasks
and speed up your work.

Customizing with Built-In Commands
You can add built-in commands or macros to the toolbars and menus in the
software. For example, the Text Box button is on the Dimension toolbar. If you use
the Text Box button more frequently than any other button on the toolbar, you
could add the Text Box button to the Main toolbar. If you want to offset elements,
you can add an Offset button to any toolbar that you want.

You can also add button commands to a menu or a menu command to a toolbar.
For example, you can place the Sheet Setup command on the Main toolbar as a
button.

To add a button to a toolbar or a command to a menu, you click the Customize
command on the Tools menu. From there, you can click the Menu or Toolbars tab
and click the options that you want.

If you want to create a new toolbar that does not exist in the software, you can start
by clicking the Toolbars command on the View menu. You then click the New
button and type the name of the new toolbar on the New Toolbar dialog box. After
you click OK, the Customize dialog box automatically appears so that you can add
buttons to the new toolbar.

Tip  When you add commands or buttons to the menus or toolbars in the software,
the changes that you made appear only if a document is open.

Customizing with Macros
Not only can you add built-in commands or buttons to the software, you can also
create your own macros that can be added to the menus and toolbars in the same
manner. The Customize command on the Tools menu allows you to add macros to
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software’s standard menus and toolbars. You can also run the macros directly by
clicking the Macro command on the Tools menu and selecting the macro.

You can create the macros in Visual Basic or other OLE-aware programming
applications. Some of the OLE-aware programming applications are VBA (inside
Excel), Visual C++ Delphi, Visual Basic, and so forth.

A type library is delivered with the software containing all the objects, properties,
and methods available with the product. On the Help menu, click Programming
with SmartSketch to access the programming Help. In the Table of Contents, you
can also get a complete reference to the objects, methods, and properties. You can
view the type library with Visual Basic’s type library browser or the browser for an
OLE-aware programming application. Practical examples of macros are also
delivered with the software.

Custom Command Macros Delivered with the
Software
The software provides custom command macros whose source can be viewed in
the \Smartsketch\CUSTOM directory. These macros have been compiled into the
\Smartsketch\CUSTOM\BIN directory. There you will find stand-alone .EXE files
and a subdirectory called OLESVR that contains OLE-server .EXE files and .DLL
files. The files in the OLESVR directory can executed directly from within the
software. A README.TXT document located in the source directory for each
macro explains how to run them.

Tip  If you did not install the macros and macros source during installation of the
software, you must run the Setup program again. In the Setup program, you must
select the Custom setup.

For example, you can run the EXTEND.EXE custom command macro inside the
software. This sample was written in Visual Basic and compiled as an OLE-server
executable program. A README.TXT document for each custom command
macro provides more details on compiling as an OLE server. You can find the
README.TXT for each custom command macro in a specific directory:
\PROGRAM FILES\Smartsketch\CUSTOM\<SAMPLE MACRO
NAME>\README.TXT. For example, the README.TXT document for
EXTEND.EXE is found in \PROGRAM
FILE\Smartsketch\CUSTOM\EXTEND\README.TXT.

For a complete list of macros, click Help and then Programming with SmartSketch.

Example: Customizing a Toolbar

With the Extend to Next button on the Draw toolbar, you can extend one line to the
next line. This command is easy and intuitive to use. However, sometimes you
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might want to extend a line a specific distance that does not depend on the location
of another element.

1. In the document, place two lines that are not connected, but are perpendicular.

2. On the Tools menu, click Customize.

3. On the Customize dialog box, click the Toolbars tab.

4. In the Categories box, click Macros.

5. Click the Browse button.

6. On the Select Macro Directory dialog box, click EXTEND.EXE in the
\PROGRAM FILES\SMARTSKETCH\CUSTOM\BIN\OLESVR directory.

Note If you cannot find the Custom directory, you must run the Setup program
again and select the Custom option.

7. Click OK.

8. On the Customize dialog box, in the Macros box, drag the EXTEND.EXE
filename out of the dialog box.

9. On the Custom Button dialog box, in the Buttons box, click the yellow happy
face button.

10. Click the Assign button.

11. The new button appears on a separate floating toolbar. Drag this toolbar over to
the top of the window and place it beside the Main toolbar.

12. On the new toolbar, click the happy face button.

13. On the Extend by Distance dialog box, in the Distance box, type 10 and press
ENTER. The dialog box automatically converts whatever you type into the
units of measure that are set for the current document. You can set the units
with the Properties command on the File menu.

14. In the document, drag the mouse over the line that you want to extend. A
preview of what the line will look like shows up in a red color.

15. Click the line to set the distance.
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16. On the Extend by Distance dialog box, click Close.

You can write your own applications that are very similar to the
EXTEND.EXE file and run them from within the current document. Click the
Programming with SmartSketch command on the Help menu to get more
information about creating your own macros.
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Adding Additional Tools to the Software
Add-ins are commands or functions that add special capabilities the software. To
install an add-in, choose the Add-Ins command from the Tools menu. After you
install an add-in, its commands or functions become an integrated part of the
software until you remove the add-in.
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Add-Ins Included with the Software
The following add-ins are included with the software and are located in the
LIBRARY directory or one of its subdirectories. If you cannot locate the add-in on
your hard disk or network drive, you can select the Macro Library option or other
add-in option in the Setup program to install these add-ins.

Add-in Description

Auto Save Automatically saves open documents at
the interval you specify.

The Wizard of ORG Creates organization charts quickly and
easily.
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Procedures to Explore in On-line Help
• Run a Macro

• Add a Button to a Toolbar

• Customize SmartSketch with the Options Command
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Managing Multi-sheet Documents
Drawing sheets are similar to pages in a notebook. You can place different
sketches or drawings on different drawing sheets in the document. For example,
you can draw one idea for a design on one drawing sheet and another idea on
another drawing sheet. Both drawings are saved in the same document. There is no
limit to the number of sheets you can have in a document.

When you create a new document, a default sheet appears with a border and a title
box. You can modify the default settings with the Sheet Setup command on the
File menu. For example, you might want to give a specific name to a sheet by
setting options with this command. If you want to insert new sheets, click the New
Sheet command on the Insert menu.

Sheets essentially act like separate drawings. Individual sheets can have different
scales and sheet borders. If you want to be able to locate or use relationships
between elements, you should place the elements on the same sheet.

You can display a number of drawing sheets on top of each other and
simultaneously view the drawings on all of the drawing sheets, much as you would
view a stack of transparencies.
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Areas of a Drawing Sheet
A drawing sheet has two areas that affect the way you work. The sheet outline (A)
shows the orientation of the sheet and the default print region of the sheet. You can
change the size and orientation of the sheet outline with the Sheet Setup command
on the File menu.

You can draw new elements on the sheet outline or outside the borders of the
outline. All new graphics that you create are placed on the active drawing sheet.

Setting Up a Drawing Sheet
You can set up a drawing sheet with the Sheet Setup command on the File menu.
The sheet where you will create most of your graphics is called a working sheet. In
a document, you can create as many working sheets as you need to plan your
project. A working sheet can have a single background sheet attached to it.

Choosing a Sheet Size
You can modify a drawing sheet’s characteristics, such as the size and scale of the
sheet, with the Sheet Setup command on the File menu. On the Sheet Setup dialog
box, you can click the Size and Scale tab and select a standard sheet size or set a
custom size. The dialog box also allows you to set the defaults for all new working
sheets created in the document. You can do this by setting the options you want
and then clicking the Save as Default button.

Drawing Sheet Scale
Drawing sheets allow you to use a specified scale as you draw. When you specify
the scale with the Sheet Setup command on the File menu, everything on the
drawing sheet is scaled except for dimensions and annotations. For example, if the
scale is one inch to ten inches and you place a line 30 inches long, the line is three
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inches long in proportion to the drawing sheet and three inches long when printed.
However, a dimension measures the length of the line as 30 inches.

The dimension and annotation sizes in your working sheets are independent of the
drawing view scale. For example, when you define the height and size of
dimension text, these values specify how you want the dimensions to appear when
you print the drawing.

The graphics on the attached background sheet are displayed at a 1:1 scale. They
are not affected by the scale set with the Sheet Setup command on the File menu.

Manipulating Drawing Sheets
At the bottom of the drawing sheet, you can see drawing sheet tabs that allow you
to manipulate and display the drawing sheets in your document. When you open a
document or create a new one, the tabs are displayed at the bottom of the work
space. There is a tab for each drawing sheet in your document.

Attaching a Background Sheet
After you set up the drawing sheet, you might want to attach a background sheet. A
background sheet is used as a backdrop to the working sheet. For example, you can
add borders to a drawing, draw a title block, insert a raster image, or draw
geometry. You can make one background sheet and attach the same background
sheet to several different drawing sheets.

When you attach a background sheet to a working sheet with the Sheet Setup
command, the items on the background sheet are displayed and printed. The size of
the working sheet is automatically set to the size of the background sheet you
attach. This is so the paper sizes and graphics on both sheets line up.

Background sheets allow you to customize your borders and title blocks so that
they match your company’s standards and requirements. You can use the
background sheet delivered in a template or design your own background sheet.
You can create tailor-made background sheets by adding your company’s logo,
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creating any other graphics that you need, and using various styles and options. A
typical customization scheme would be to have a different background sheet for
each standard-sized drawing (A, B, C, D; or A0, A1, A2, A3, A4).

Sheets and Document Templates
You can re-use your sheets by creating and saving them in a document template.
When you create a new document based on a template, all of the drawing sheets
that are part of the template are copied into your new document.
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Printing Documents
You can print your documents on many different devices ranging from dot matrix
printers to high-end laser printers. Except for the color settings and a few special
effects, your drawing prints exactly as it appears on the drawing sheet.

Preparing to Print
The printer you use affects the way the current document prints and displays text
on the screen. Before you print a document, you must install and select the printer
that you want to use. For more information about installation, see your printer
documentation.

Before you print, you will want to choose a printer and the settings for it. To do
this, click the Print command on the File menu and then click the printer that you
want to use. You can set properties for the printer by clicking the Properties button.
To set the print range and scale, click the Settings button.

Printing a Document
As you work on a document, you might need to send a copy of it to a specified
printer, plotter, or file.  You can click the Print command on the File menu to do
the following:

• Print an entire document or specific sheets from a document.

• Print a draft copy of a document.

• Set printing options, such as the range of sheets or number of copies to print.

The software supports WSYWIG plotting, using standard Windows NT plotting
capabilities. The software also supports pen plotters, subject to the limitations of
the device driver. Elements appear the same on the screen and in the printed
document.

However, the fonts that you choose can affect the match between what you see on
the screen and what appears on the printed page. Three kinds of fonts affect your
work: scalable fonts, printer fonts, and screen fonts. Use scalable fonts, such as
TrueType® fonts, to confirm that what you see on the screen is what appears on
the printed page. If you use printer fonts, you must have a corresponding screen
font and font size to display each font on the screen. If each screen font you use has
a matching printer font, the screen display of the document will closely match the
printed document.
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Printing Part of a Document
You can print selected sheets in a document or a selected area. This practice is
handy if you are working on a complex drawing and you want to print only certain
parts to proof them.

To print selected sheets, you should first select sheets in the document to make
them active. To do this, you can click the drawing sheet tabs of the sheets that you
want while pressing Ctrl. Then, you select the Print command on the File menu and
click the Selected Sheets option on the dialog box.

When you select several sheets and then click the Selected Sheets option on the
Print dialog box, all the selected sheets are printed as one composite drawing, like
layers on top of one another. The software uses the scale, paper size, and
orientation of the active sheet for printing the final document.

To print a selected area, you should first select the drawing sheets that you want to
print. Then, you select the Print command on the File menu and click the Print Area
option on the dialog box. After you click the OK button, a set of crosshairs appears.
You drag over the area that you want to print. The Print Area dialog box then
automatically appears and allows you to set options for printing the selected area.

Printing Time
Required time for printing varies by document. Expect longer print times when you
have drawings that contain a large number of the following items:

• Curved elements

• Many fills that have complex colors, patterns, or textures

• Large bitmaps

• Links to various documents

The type of printer that you have also affects the printing time. PostScript® printers
print faster than LaserJet printers because they can calculate faster. Some older
versions of PostScript printers are slower when compared to the newer ones. The
type of controller boards and the amount of RAM in the printer also affect your
printing times.
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Saving Documents
When you first save a new document, the software provides a default name and
directory location. You can give the document a meaningful name and specify
where you want to store the document on the disk.

When you open an existing document, the software copies the document from the
disk and displays it on the screen. As you work, the changes you make to the
document are displayed on your screen. To preserve these changes, you must save
the document. When you save the document with the Save command, the changes
are copied to the document on the disk.

Tip  You can quickly save changes to an open document by clicking the Save
button on the Main toolbar.

After you have saved a document, it remains displayed on the screen. You can use
the Close command to close the document and clear it from your screen, or you can
use the Exit command to close the document and exit the software.

Saving a Copy
If you need to make a copy of your work, you can click the Save As command on
the File menu. You should type a different name for the document in the Save As
dialog box.

Saving a Document as a Template
Sometimes you might want to make a copy of the same document as a starting
point for creating other documents. In these cases, you can create a template to use
as a starting point for many different drawings. A template is a collection of
settings that you use over and over in different drawings. The settings might
include drawing sheet settings, scales, actual elements that you draw, and a
background sheet.

To create a template, just save the current document with the Save As Template
command on the File menu. This command saves the document in the
TEMPLATE directory located in the directory where you installed the software. A
different file extension in the name of the document is not necessary. To base new
documents on the template, choose the New command on the File menu and select
the template from the list. You can also open the template and save the document
under another name.
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Tip  You can change the directory where templates are saved by selecting the
Options command on the Tools menu and setting the directory that you want on the
File Locations tab of the Options dialog box.

Saving Documents to CGM Format
The Computer Graphics Metafile (.CGM) provides an efficient way to make
information available on the Internet. You can use the Save As command to save
documents in .CGM format. Once in .CGM format, you can place the graphics on
a web page (.HTML or .HTM) and view them with browsers such as the Internet
Explorer or Netscape Navigator.

CGM is an efficient format for publishing 2D vector drawings on the Web because
it takes up little storage space, renders quickly, and has the ability to zoom and
achieve more detail. These types of drawings can contain embedded hyperlinks,
allowing quick access to information outside the drawing.

Saving Documents to HTML Format
In addition to the CGM format, you can use the Save As Web Page command to
save documents in .HTML format. This command saves the document in an
HTML document; the graphics in the document are embedded in the HTML as
.CGM graphics. You can then view the document with browsers such as the
Internet Explorer or Netscape Navigator.

Closing a Document
If you want to close a document without saving your work, click the Close
command on the File menu and then, when prompted to save your work, click the
No button. If you want to save your work, you can click the Yes button instead. If
you decide not to close the document at all, you can click the Cancel button.

Sending a Document to Others
After you finish drawing a sketch or adding notes to it, you can send the document
to other users by clicking the Send command on the File menu. An e-mail message
appears, allowing you to attach the drawing to the message. You can also embed or
link the drawing to a Word document and send the document in e-mail to other
users.
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Saving a Document Automatically
You can set option to automatically save open documents at the interval that you
specify. This safety feature prevents you from losing work in case of an unexpected
system shutdown. You can set several options for AutoSave, including how often
to save, which documents to save, and whether to be prompted for each save. You
can use AutoSave when you have one or more documents open.

Caution  If the AutoSave option does not appear on the Tools menu, you must
install it by clicking Add-Ins on the Tools menu.
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 Procedures to Explore in On-line Help
• Create a Document

• Create a Template

• Set Up a Drawing Sheet

• Add Styles to the Current Document

• Set the Unit of Measure

• Create a New Drawing Sheet

• Print a Document
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Opening and Saving MicroStation Files

Opening and Saving MicroStation Files
SmartSketch supports opening and saving MicroStation files in two ways: you can
either select a MicroStation file and translate it into equivalent SmartSketch
elements, or you can create a reference file from a MicroStation file.

If you use the method for selecting a MicroStation file and translating it into
equivalent SmartSketch elements, you can click Open on the File menu. Once a
MicroStation file has been opened using this method, the resulting file is in a
SmartSketch format (IGR).

Tip  If the MicroStation file extension is not a .DGN extension, you may need to
use a utility to define other extensions as MicroStation files.

If you use the method for creating a reference file from a MicroStation file, you can
either click Object on the Insert menu, or you can drag and drop from the Symbol
Explorer or Windows Explorer. This enables you to display and, if MicroStation is
available on your PC, edit the MicroStation file while working in SmartSketch.
You can also select the view position of a 3-D MicroStation file upon placement.
Once a MicroStation file has been referenced using this method, you can then
locate and establish relationships between the new information and elements on the
drawing sheet.

Note  The Options command on the Tools menu displays the Options dialog box.
By selecting the Foreign Data tab and setting the format to MicroStation, you can
configure the settings for importing MicroStation data that applies to both of these
methods.

Caution  Roundtrip of MicroStation data (importing MicroStation data to
SmartSketch data and exporting back to MicroStation data) is currently supported
visually. Data fidelity for information such as tags, database linkages, and user data
are not supported during export to the MicroStation file format.

Other Methods for Importing MicroStation Data
You can use the following methods to move MicroStation (.DGN) documents into
SmartSketch:

• Cutting and pasting.

• Dragging and dropping.
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• Inserting the information as an object.

When you open a MicroStation document that has references to other documents,
those referenced documents show up as well. You can locate referenced
documents in the current document.

Tip  You can also use the Open command on the File menu to translate and open
documents. You can use seed files to preserve the document’s original fonts and
line types when you open a MicroStation document.

Cutting and Pasting
You can select the information in the MicroStation document and then cut or copy
the information and paste it into SmartSketch with the Paste Special command.

Dragging and Dropping
You can select the information in the MicroStation document and then drag and
drop it into SmartSketch. In the Windows Explorer, select the MicroStation
document and then drag and drop it into SmartSketch. The document will be
embedded in the drawing by default. Right before you drop the document, you can
embed the document in SmartSketch by pressing the CTRL key. If you press
CTRL + SHIFT, the document is linked. When you drop the document, handles
appear that allow you to scale the object. The foreign document is placed into
SmartSketch and behaves much like a symbol, allowing you to click to place it or
move it around.

Tip  You can set placement options by clicking the Options command on the Tools
menu. Then, you can set the options you want on the Reference File tab of the
Options dialog box.

Inserting as an Object
Inside SmartSketch, you can insert the entire foreign document with the Object
command on the Insert menu. On the Insert Object dialog box, you can set the
option to link or embed the document. After you insert the object, SmartSketch
places a SmartFrame border around the object, allowing you to crop it without
altering the scale of the object. The geometry of the inserted document is
recognized; you can use the relationship indicators to draw or create relationships
between the geometry of the inserted object and other elements in the SmartSketch
document. You can edit the inserted object by double-clicking it.
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Tip The Object command inserts any OLE 2.0 enabled object, such as a Word or
.AVI document, or CAD document, such as .DGN. The inserted object can then be
edited by double-clicking it.

Saving SmartSketch to MicroStation
You can save a SmartSketch document as a MicroStation document. Before you do
this, you can adjust the translation options with the Options command on the Tools
menu. On the Foreign Data tab, you can click the Export Options button.

When you save a SmartSketch document as a .DGN document, the active sheet is
saved. On the Options dialog box, you can map SmartSketch layers to
MicroStation levels (1–63). All the remaining layers are placed on the last layer or
level of the foreign document. The layer names are preserved, whether importing
or exporting MicroStation documents.

Caution  If you save a SmartSketch document with raster reference files as
MicroStation documents, only the files of the same type (.DGN) can be exported
back into SmartSketch.
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Accuracy of MicroStation Data During Import
When you translate MicroStation data into SmartSketch, you are concerned with
either Visual fidelity, Data fidelity, or both.

Visual Fidelity
Visual fidelity is a phrase used to describe the visual accuracy of a picture after
translation. SmartSketch preserves the visual accuracy of a MicroStation file by
providing support for the following areas:

Colors
MicroStation maintains a fixed number of colors in a color table for each
document. Because SmartSketch uses true color, the color table of the seed file is
used as the basis of the translation. The default color table provided with
SmartSketch defines the first 16 colors as standard and fills in the rest of the colors
as they are needed. If the color table is full, then each color is matched to the
closest MicroStation color. MicroStation colors are automatically translated to the
closest red, green, blue (RGB) values in SmartSketch.

Widths
SmartSketch provides a default set of line widths that corresponds to standard
metric pencil leads: .13, .18, .25, .35, .5, .7, 1.0, 1.4, and 2.0. When you open a
MicroStation document, a default mapping determines which SmartSketch line
width is assigned to go with which MicroStation weight. You can change any of
the default mappings to define your own mapping with the Line Width tab of the
MicroStation Import Options dialog box (accessed through the Foreign Data tab
after you select the Options command on the Tools menu).

Linestyles
The core MicroStation linestyles 0-7 default to matching SmartSketch linestyles,
unless they are mapped on the Linestyle tab of the MicroStation Import Options
dialog box. MicroStation User Defined Line Styles (UDLS) are supported directly.
If you use the Style Resources dialog box, you can attach a MicroStation linestyle
resource (*.RSC) file as a resource for linestyles to use in a document.
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Patterns
MicroStation associative patterns are automatically recreated as fill styles in the
resulting SmartSketch files. Non-associative MicroStation patterns are imported as
groups.

Font Styles
SmartSketch supports the system TrueType fonts delivered with Windows NT and
supplies additional ANSI and ISO TrueType™ engineering fonts. SmartSketch
also supports MicroStation fonts. When you open a .DGN document, SmartSketch
provides a default mapping to determine which TrueType font is assigned to which
MicroStation font. You can change to this mapping to define your own mapping.
You can change the mapping with the Options command on the Tools menu. On
the File Locations tab, you can set the paths to the font resources by double-
clicking on Fonts 1, 2, and 3.

References
MicroStation references are imported as SmartSketch reference files, which use the
automatic defaults or same options for configuring how color, weights, line styles,
patterns, and fonts are handled for visual accuracy.

Tips
• ImageScape LT must be downloaded to support import of raster reference

fil es.

• None of the data that is part of the reference file can be deleted or altered using
SmartSketch commands. However, if MicroStation software is installed on
your computer, then you can click Open on the Shortcut menu over the
reference file. This action opens the MicroStation reference file in the
MicroStation application.

• If  you establish relationships between elements in the SmartSketch file and a
reference fil e, the relationships will be removed if you change the position of
elements in the source file and then update the reference file in SmartSketch.

• If you change the inserted information (copied from MicroStation), the original
information does not change.
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Configuring the Fit to Sheet Feature
SmartSketch automatically calculates the sheet scale when you import
MicroStation documents so that the range of graphics automatically fits within the
lower left-hand corner of the drawing sheet.  If you do not want the sheet scale
automatically calculated, then you must manually modify the INI file.

To modify the INI file, you click Explore on the Start menu and go to the directory
where SmartSketch resides. You can use any text editor to modify the file. Double-
click itmstn. In the [Options] section of the file, set Ignore sheet scale = 0.

Tip  You can create a template for calculating sheet scale at the scale you want and
insert a MicroStation document to base the template on. On the Sheet Setup dialog
box, you set the Drawing Scale and Paper Units that you want.

Using MicroStation Fonts and Styles in a
SmartSketch Document
If you want to make line styles from MicroStation resource files available in a
SmartSketch document, you can reference the styles with style resource
documents. You can reference a MicroStation .RSC file from the active template or
document by clicking the Resources button on the Styles dialog box.

When you attach a .RSC file from the current document or template, the styles in
the resource document are added to the Style dropdown list on the ribbon bar for
the active document.

Tip  MicroStation resource files for line styles are treated as a document setting. If
you want to have all documents that are created by importing use the same styles,
you must create an .IGR template with those styles attached. You then specify the
.IGR template as the template to use during import of MicroStation documents.

Data Fidelity
Data fidelity is a phrase that describes how accurately the data is preserved when
compared to its original form in the application that created it. SmartSketch
preserves the data accuracy of a MicroStation file by providing equivalent element
types with mapped entities to SmartSketch. SmartSketch also provides support for
non-displayed data such as database linkages, units, and coordinates.

SmartSketch preserves data accuracy of a MicroStation file by providing support
for the following areas:
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Units
MicroStation files are determined by the master and sub-unit labels in the file.

• If meaningful master units and sub-units are found, the resulting SmartSketch
document has the closest matching units set on the Units tab of the Properties
dialog box.

• If no meaningful master units and sub-units are found, the File Units setting in
the Import area of the Options dialog box is used to determine the units for
translated or referenced MicroStation files.

Coordinates
MicroStation data is automatically positioned to matching coordinate positions
when you translate the MicroStation files (click  Open on the File menu).
Referenced MicroStation file coordinate positions are determined by the settings on
the Reference File tab on the Options dialog box.

Tip  You can use the Coincident option to import the data in its original coordinate
position at a 1 to 1 scale.

Levels
MicroStation level numbers, names, or both are preserved as SmartSketch layer
names, but the color and linetype settings (level symbology) are not. The color and
linestyle settings apply directly to the resulting elements.

Within a SmartSketch document, there are an unlimited number of layers per sheet.
When translating foreign files into SmartSketch, the levels in MicroStation keep the
same names. The MicroStation Export Options dialog box provides a layer
mapping table, due to the limit of 63 levels in MicroStation. You can access this
dialog box with the Foreign Data tab after you select the Options command on the
Tools menu.

Cells
When you translate a .DGN document, the default is to translate cells into symbols.
You can change this default with the Options command on the Tools menu so that
cells or blocks are embedded groups. This action translates cells and blocks into
embedded symbols, or groups, in SmartSketch.
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Tip  All MicroStation Type 2 cells are imported into SmartSketch as a group. The
group contains a dynamic attribute set that stores the name of the cell, its origin,
and any other data characterizing the cell. There is, therefore, enough information
stored in the group to reconstruct an element back into a cell to export in the future.

When you import a MicroStation document that has cells, a temporary folder is
created in the Temp folder on your computer. The temporary folder contains the
symbols that are embedded in the MicroStation document. By default, these
symbols are deleted after the document is imported into the drawing sheet. You can
change a setting in \\Smartsketch\PROGRAM \ITMSTN.INI to save the symbols
instead. In Notepad, open the .INI file and change the following line in the Options
section: Delete Symbol Definitions = 0.

3D Data
All 3D data is flattened into a 2D view when you translate files using Open on the
File menu. The 2D view orientation is determined by the Orientation setting in the
Import area of the Options dialog box.

The following information is an entity-to-element map when you translate files
using Open on the File menu.

MicroStation SmartSketch

Line Line

Linestring Linestring

Bspline Curve Bspline Curve

Shape Linestring

Ellipse Ellipse

Arc Arc

Complex String Complex String

Complex Shape Complex String

Bspline Surface Bspline Curve

Curve Bspline Curve

Cone Flattened wire frame

Surface Group

Dimension Dimension
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Text Text

Text Node Text

Cell Group

Shared Cell Symbol (Shared Embed)

Multiline Group

Point String Points

Reference Reference

Raster Reference

Database Linkages Dynamic Attribute set on the element

Tags Dynamic Attribute set on the element

User Data Dynamic Attribute set on the element
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Accuracy of MicroStation Data During Export
When you translate SmartSketch files into MicroStation data, you are concerned
with either Visual fidelity, Data fidelity, or both.

Visual Fidelity
Visual fidelity is a phrase used to describe the visual accuracy of a picture after
translation. SmartSketch preserves the visual accuracy of a file during export to
MicroStation by providing support for the following different areas:

Colors
When SmartSketch colors are saved to a .dgn file, a color table containing
matching colors is created and attached to the resulting .dgn by default. If a seed
file with a color table attached is specified on the MicroStation Export Options
dialog box (accessed through the Foreign Data tab after you select the Options
command on the Tools menu), SmartSketch colors are automatically mapped to the
closest RGB equivalent colors in that table.

Widths
SmartSketch default widths are pre-mapped to their most equivalent MicroStation
widths on the Line Width tab of the MicroStation Export Options dialog box
(accessed through the Foreign Data tab after you select the Options command on
the Tools menu).

Linestyles
SmartSketch line styles are mapped on the Linestyle tab of the MicroStation Export
Options dialog box. If styles from a referenced MicroStation .RSC file have been
used in the SmartSketch file being exported, the line style names are transferred to
the resulting .dgn file. If a style exists in the MicroStation application by the same
name, that style will be used. If there is no style in the MicroStation application by
the same name, MicroStation assigns a default style.

Fill Styles
Basic fill styles such as Normal are automatically recreated as MicroStation
associative hatch patterns in the resulting .dgn files. Fill styles that use symbols
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such as Earth (in AEC templates) are exported as individual elements in the
resulting .dgn file.

Font Styles
SmartSketch default font styles (TTF) are pre-mapped to their most equivalent
MicroStation font styles on the Font tab of the MicroStation Export Options dialog
box. If the font is not listed in the mapping table on the font tab, it defaults to font 3
(Engineering) in the resulting MicroStation file. If font styles from a referenced
MicroStation .RSC file have been used in the SmartSketch file being exported, the
font style names are passed into the resulting .dgn file, provided it has not been
mapped in the font mapping table. Mappings override automatic behaviors. If a
font style exists in the MicroStation application by the same name, that font style
will be used. If there is no font style in the MicroStation application by the same
name, MicroStation assigns the default font 3 (Engineering) style.

References
MicroStation .dgn files that are referenced in SmartSketch will be saved as
MicroStation reference files in the resulting MicroStation file. Raster reference files
in SmartSketch will be saved as MicroStation raster files in the resulting
MicroStation file. Other reference files (.igr, .dgn, .or dxf files) are not currently
supported during the export to MicroStation. Inserted objects such as .XLS, .DOC,
or .BMP are not currently supported during the export to the MicroStation file
format.

Multiple Sheets
Only the active sheet and background sheet in a SmartSketch file is exported to a
MicroStation file. Exporting multiple sheets from a document is not currently
supported.

Tip  The active background sheet graphics are merged into the resulting .dgn file.

Data Fidelity
Data fidelity is a phrase used to describe how accurately the data is preserved when
compared to its original form in the application that created it. SmartSketch
preserves the data accuracy of a MicroStation file during export by mapping data to
its most equivalent form in MicroStation. SmartSketch does not support exporting
data such as attribute sets that can be associated with elements in the file.



 MicroStation Documents in SmartSketch Chapter 19

271

SmartSketch preserves data accuracy of a MicroStation file by providing support
for the following areas:

Units
If a seed file is specified on the MicroStation Export Options dialog box, then the
units of that seed file are used in the resulting file. Otherwise, the following chart
indicates what happens to SmartSketch units as they are exported to MicroStation
units.

igr Primary Units MSTN MU MSTN Resolution

inches IN 1000:254

feet FT 12:8000

meters M 1000:10

millimeters MM 1000:100

centimeters CM 1000:100

manometers NM Seed file values unchanged

yards YD Seed file values unchanged

miles MI Seed file values unchanged

kilometers KM Seed file values unchanged

tenths TE Seed file values unchanged

hundreds HN Seed file values unchanged

thousands TH Seed file values unchanged

poles PL Seed file values unchanged

rods RD Seed file values unchanged

links LK Seed file values unchanged

chains CH Seed file values unchanged

points PT Seed file values unchanged

furlongs FR Seed file values unchanged
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Coordinates
SmartSketch data is automatically positioned to matching coordinate positions
when you translate to the MicroStation files.

Layers to Levels
SmartSketch layer names are preserved as MicroStation level names and numbers,
but the color and linestyle settings (level symbology) are not. The color and
linestyle layer settings are applied directly to the resulting elements.

Tip  Any translated levels past Level 63 are combined together on Level 63.

The following is an element to element map when you translate files using  Save
As on the File menu.

SmartSketch MicroStation

Line Line

Ellipse Ellipse

Arc Ellipse

Point Line

Linestring Linestring

Connector Linestring

Bspline Curve Bspline Curve

Rectangle Shape

Complex String Complex Chain

Text Text

Dimension Dimension

Symbol Shared Cell

Leader Dimension

Group Group

SmartLabel Elements

Parametric Symbols Elements
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Multi Representation
Symbol

Elements

.dgn Reference .dgn Reference

.igr, dwg, or .dxf
Reference

Ignored (no equivalent)

OLE Objects (.doc,
.xls, etc.)

Ignored (no equivalent)

Attribute sets Ignored

Raster Reference Raster Reference
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MicroStation Cells in SmartSketch
To use MicroStation cells as symbols in SmartSketch, the cells must first be
converted into individual SmartSketch symbols (.SYM). On the File menu, the
Open command allows you to open a MicroStation cell library. A directory will be
created, with the same name as the cell library. The individual cells within the
library will be saved as individual SmartSketch symbols in the new directory.

Tip  All MicroStation Type 2 cells are imported into SmartSketch as a group. The
group contains a dynamic attribute set that stores the name of the cell, its origin,
and any other data characterizing the cell. There is, therefore, enough information
stored in the group to reconstruct an element back into a cell to be exported in the
future.

You can drag these SmartSketch symbols from the Symbol Explorer or Windows
Explorer into other SmartSketch documents.

Options for the cell library units (SU and PU) can be set on the MicroStation
Import Options dialog box. You can access this dialog box by clicking the Options
command on the Tools menu. Then, on the Foreign Data tab, you can enter the
appropriate working units in the SU: and MU: fields.

SmartSketch symbols are saved as MicroStation cells during translation from
SmartSketch to MicroStation formats.
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MicroStation Construction Class Information
When you open a MicroStation document, the construction class information is
preserved with layer names. When importing the document, the software creates
special layers for construction elements. The layers are named so that you can
recognize the layers, including the layer for the construction element. For example,
level 6 would become Constr. 6 and level Border would also become Constr.
Border. You can also save these layers back out to the MicroStation document
format.
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 Procedures to Explore in On-line Help
• Establish Relationships on a MicroStation Reference File

• Open a MicroStation Cell Library

• Add MicroStation Linestyles to a Document

• Open a MicroStation Document

• Place MicroStation Information in the Document
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Opening and Saving AutoCAD Files

Opening and Saving AutoCAD Files
SmartSketch supports opening and saving AutoCAD files in two ways: you can
either select an AutoCAD file and translate it into equivalent SmartSketch
elements, or you can create a reference file from an AutoCAD file.

If you use the method for selecting an AutoCAD file and translating it into
equivalent SmartSketch elements, you can click Open on the File menu. Once an
AutoCAD file has been opened using this method, the resulting file is in a
SmartSketch format (IGR).

Tip  If an AutoCAD file contains paper space data, the resulting SmartSketch file
will contain two sheets: one sheet represents the paper space data, and is named
paper space; the other sheet represents model space data, and is named model
space. The paper space views are recreated as reference views of the model sheet
on the paper space sheet.

If you use the method for creating a reference file from an AutoCAD file, you can
either click Object on the Insert menu, or you can drag and drop from the Symbol
Explorer or Windows Explorer. This enables you to display and, if AutoCAD is
available on your PC, edit the AutoCAD file while working in SmartSketch. You
can also select the view position of a 3-D AutoCAD file upon placement. Once an
AutoCAD file has been referenced using this method, you can then locate and
establish relationships between the new information and elements on the drawing
sheet.

Note  The Options command on the Tools menu displays the Options dialog box.
By selecting the Foreign Data tab and setting the format to AutoCAD, you can
configure the settings for importing AutoCAD data that applies to both of these
methods.

Caution  Roundtrip of AutoCAD data (importing AutoCAD data to SmartSketch
data and exporting back to AutoCAD data) is currently supported visually. Data
fidelity for information such as attributes, database linkages, and Xdata are not
supported during export to the AutoCAD file format.
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Other Methods for Importing AutoCAD Data
You can use the following methods to move AutoCAD (.DWG or .DXF) files into
SmartSketch:

• Cutting and pasting.

• Dragging and dropping.

• Inserting the information as an object.

When you open an AutoCAD document that has references to other documents,
those referenced documents show up as well. You can locate referenced
documents in the current document.

Tip  You can also use the Open command on the File menu to translate and open
documents.

Cutting and Pasting
You can select the information in the AutoCAD document and then cut or copy the
information and paste it into SmartSketch with the Paste Special command.

Dragging and Dropping
You can select the information in the AutoCAD document and then drag and drop
it into SmartSketch. In the Windows Explorer, select the AutoCAD document and
then drag and drop it into SmartSketch. The document will be embedded in the
drawing by default. Right before you drop the document, you can embed the
document in SmartSketch by pressing the CTRL key. If you press CTRL + SHIFT,
the document is linked. When you drop the document, handles appear that allow
you to scale the object. The foreign document is placed into SmartSketch and
behaves much like a symbol, allowing you to click to place it or move it around.

Tip  You can set placement options by clicking the Options command on the Tools
menu. Then, you can set the options you want on the Reference File tab of the
Options dialog box.

Inserting as an Object
Inside SmartSketch, you can insert the entire foreign document with the Object
command on the Insert menu. On the Insert Object dialog box, you can set the
option to link or embed the document. After you insert the object, SmartSketch



Chapter 20 SmartSketch Getting Started Guide

280

places a SmartFrame border around the object, allowing you to crop it without
altering the scale of the object. The geometry of the inserted document is
recognized; you can use the relationship indicators to draw or create relationships
between the geometry of the inserted object and other elements in the SmartSketch
document. You can edit the inserted object by double-clicking it.

Tip  The Object command inserts any OLE 2.0 enabled object, such as a Word or
.AVI document, or CAD document, such as .DWG. The inserted object can then
be edited by double-clicking it.

Saving SmartSketch to AutoCAD
You can save a SmartSketch file as an AutoCAD file. Before you do this, you can
adjust the translation options with the Options command on the Tools menu. On the
Foreign Data tab, you can click the appropriate Export Options button.

When you save a SmartSketch document as a .DWG or .DXF document, the active
sheet is saved.

You do not have to map layers for AutoCAD documents; the layer names are
imported or exported as named in the native document. If a SmartSketch layer has
not been mapped, it is automatically placed on the next available layer or level in
the foreign document until the last level or layer has been encountered.

Caution  If you save a SmartSketch document with raster reference files as
AutoCAD documents, only the files of the same type (.DWG) can be exported
back into SmartSketch.
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Accuracy of AutoCAD Data During Import
When you translate AutoCAD data into SmartSketch, you are concerned with
either visual fidelity or data fidelity or both.

Visual Fidelity
Visual fidelity is a phrase used to describe the visual accuracy of a picture after it
has been translated. SmartSketch preserves the visual accuracy of an AutoCAD file
by providing support for the following seven different areas:

Colors
AutoCAD colors are automatically mapped to the closest matching red, green, blue
(RGB) color in the SmartSketch color table.

Tip  Colors that were used in AutoCAD to determine plotting pen widths can also
be mapped to a SmartSketch width by using the AutoCAD Color option on the
Line Width tab of the AutoCAD Import Options dialog box.

Widths
AutoCAD polylines are the only type of entity that support a width. Polyline widths
are automatically mapped to an exact matching in SmartSketch model width. All
other entities such as lines, arcs, and circles in AutoCAD do not support width. For
the entities that do not support width, a default width is applied (all elements in
SmartSketch have a width). You can make changes to any of the default mappings
to define your own mapping with the Line Width tab of the AutoCAD Import
Options dialog box (accessed through the Foreign Data tab after you select the
Options command on the Tools menu). SmartSketch provides a default set of line
widths that correspond to standard metric pencil leads: .13, .18, .25, .35, .5, .7, 1.0,
1.4, and 2.0.

Linestyles
AutoCAD default line styles are pre-mapped to the most equivalent SmartSketch
line styles on the Linestyle tab of the AutoCAD Import Options dialog box. Line
styles other than the default line styles or any complex line styles containing shapes
are mapped to continuous unless they are specifically mapped on the Linestyle tab.
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Hatches
AutoCAD default hatches are automatically mapped to matching fill styles in the
resulting SmartSketch files. Hatches other than the defaults delivered with
AutoCAD are stroked into their primitive elements to preserve their visual
accuracy

Font Styles
AutoCAD default Font styles are pre-mapped to their most equivalent SmartSketch
Font styles, True Type Fonts, on the Font tab of the AutoCAD Import Options
dialog box. Other fonts default to the Arial true type font delivered with Windows.
If the font is not listed in the mapping on the tab, it defaults to Arial.

Xrefs
AutoCAD Xrefs are imported as SmartSketch reference files, which use the
automatic defaults or same options for configuring how color, width, line styles,
hatches, and fonts are handled for visual accuracy.

Tips
• ImageScape LT must be downloaded to support raster reference files.

• None of the data that is part of the reference file can be deleted or altered using
SmartSketch commands. However, if AutoCAD software is located on your
machine, then you can click Open on the Shortcut menu over the reference file.
This will open the AutoCAD reference file in the AutoCAD application.

• If you establish relationships between elements in the SmartSketch file and a
reference file, the relationships will be removed if you change the position of
elements in the source file and then update the reference file in SmartSketch.

• If you change the inserted information (copied from AutoCAD), the original
information does not change.

Paper Space
If paper space was active when an AutoCAD file was saved, the file containing
paper space data causes two sheets to be created when you click Open on the File
menu. One sheet represents the paper space data and is named Paper Space. The
other sheet represents model space data and is named Model Space. The paper
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space views are recreated as reference views of the model sheet on the paper space
sheet.

Tip  AutoCAD files that are reference files instead of files translated using Open
on the File menu, do not support the display of paper space data; instead, the model
space information is displayed.

Configuring the Fit to Sheet Feature
SmartSketch automatically calculates the sheet scale when you import AutoCAD
documents so that the range of graphics automatically fits within the lower left-
hand corner of the drawing sheet.  If you do not want the sheet scale automatically
calculated, then you must manually modify the INI file.

To modify the INI file, you click Explore on the Start menu and go to the directory
where SmartSketch resides. You can use any text editor to modify the file. Double-
click itacad. In the [Options] section of the file, set Ignore sheet scale = 0.

Tip  You can create a template for calculating sheet scale at the scale you want and
insert an AutoCAD document to base the template on. On the Sheet Setup dialog
box, you set the Drawing Scale and Paper Units that you want

Using AutoCAD Fonts and Styles in a SmartSketch
Document

Fonts
SmartSketch supports the system TrueType fonts delivered with Windows and
supplies additional ANSI and ISO TrueType™ engineering fonts. When you open
a .dwg document, SmartSketch provides a default mapping to determine which
TrueType font will be assigned to which AutoCAD font. You can make changes to
this mapping to define your own mapping. You can change the mapping with the
Options command on the Tools menu. On the File Locations tab, you can set the
paths to the font resources by double clicking on Fonts 1, 2, and 3.

Data fidelity
Data fidelity is a phrase used to describe how accurately the data is preserved when
compared to its original form in the application that created it. SmartSketch
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preserves the data accuracy of an AutoCAD file by providing equivalent element
types that entities are mapped to. SmartSketch also provides support for non-
displayed data such as attributes on the resulting elements.

SmartSketch preserves data accuracy of an AutoCAD file by providing support for
the following areas:

Units
AutoCAD files are considered unit-less files. The File Units setting for AutoCAD
import data on the Options dialog box is used to determine the units for translated
AutoCAD data or referenced AutoCAD data.

Coordinates
AutoCAD data is automatically positioned to the matching coordinate positions
when you translate the AutoCAD files (click Open on the File menu). Referenced
AutoCAD file coordinate positions are determined by the settings on the Reference
File tab on the Options dialog box.

Tip  You can use the Coincident option to import the data in its original coordinate
position at a 1 to 1 scale.

Layers
Within a SmartSketch document, there are an unlimited number of layers per sheet.
AutoCAD layer names are preserved as SmartSketch layer names, but the color
and linetype settings are not. The color and linestyle settings are applied directly to
the resulting element.

Caution  In AutoCAD, colors, line styles, and line widths are applied on a layer-
by-layer basis. When you select a different layer, the colors, line styles, and line
widths change. In SmartSketch, colors, line styles, and line widths are applied
directly to each individual element or object. When you select a different layer, the
colors, line styles, and line widths are not affected. When you export back to
AutoCAD, colors, line styles, and line widths are applied on an entity basis.

AutoCAD entity colors & linetypes are determined one of three ways on an
element:

• Byblock−a property that specifies that an entity inherit the color or linetype of a
block containing it. SmartSketch does not support the entity concept so the
Byblock properties are applied directly to the resulting element.
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• Bylayer−a property that specifies that an entity inherit the color or linetype of
its associated layer. SmartSketch does not support the entity concept so the
Bylayer properties are applied directly to the resulting element.

• Byentity−occurs when colors and linetypes are directly applied to the entity and
override any Byblock or Bylayer properties. SmartSketch supports this concept
for all of its elements and preserves Byentity properties for colors and
linestyles.

Blocks
When translating a .dwg document, the default is to translate cells or blocks into
symbols. You can change this default with the Options command on the Tools
menu so that cells or blocks are embedded groups. This translates cells and blocks
into embedded symbols, or groups, in SmartSketch.

When you import an AutoCAD document that blocks, a temporary folder is created
in the Temp folder on your hard drive. The temporary folder contains the symbols
that are embedded in the AutoCAD document. By default, these symbols are
deleted after the document is imported into the drawing sheet. You can change a
setting in \\SMARTSKETCH\PROGRAM \ITACAD.INI to save the symbols
instead. In Notepad, open the .INI file and change the following line in the Options
section: Delete Symbol Definitions = 0.

3D Data
All 3D data is flattened into a 2D view when you translate files using Open on the
File menu. The 2D view orientation is determined by the Orientation setting in the
Import area of the Options dialog box.

The following is an entity to element map when you translate files using Open on
the File menu.

AutoCAD SmartSketch

Line Line

Circle Ellipse

Polyline (lines only) Linestring

Polyline (lines & arcs) Complex String

Arc Arc

Trace Line
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Point Point

Face3d Line

Solid Linestring

Block Symbol

Multiline Linestring

Spline Bspline Curve

Dimension Dimension

Text Text

Paperspace Viewport Reference

Xline Line

Ray Line

Database Linkages Dynamic Attribute set on element

Attributes Dynamic Attribute set on element

Ellipse Ellipse

Region Ignored

Solid3d Ignored

Mtext Text

Leader Leader

Tolerance Group

Xdata Dynamic Attribute set on the element

Hatch Fill

Image Reference
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Accuracy of AutoCAD Data During Export
When you translate SmartSketch files into AutoCAD data, you are concerned with
either Visual fidelity or Data fidelity or both.

Visual Fidelity
Visual fidelity is a phrase used to describe the visual accuracy of a picture after it
has been translated. SmartSketch preserves the visual accuracy of a file during
export to AutoCAD file by providing support for the following seven different
areas:

Colors
SmartSketch colors map to the closest matching red, green, blue (RGB) color in
the default AutoCAD color table.

Tip SmartSketch widths can be mapped to an AutoCAD color by using the Line
Width tab of the AutoCAD Export Options dialog box. AutoCAD colors are used
to determine plotting pen widths.

Widths
Every element in SmartSketch has widths applied that are exported as polyline
objects with equivalent AutoCAD widths if the widths are equal to or greater than
the polyline width threshold. The Polyline width threshold field is located on the
Line Width tab of the AutoCAD Export Options dialog box. Whenever possible,
elements that have widths less than the threshold are exported as AutoCAD entities
that do not support width.

Linestyles
SmartSketch default line styles are pre-mapped to the most equivalent AutoCAD
line styles on the Linestyle tab of the AutoCAD Export Options dialog box. Line
styles other than the default line styles or any complex line styles containing shapes
are mapped to continuous unless they are specifically mapped on the Linestyle tab.

Fill Styles
SmartSketch default fill styles are exported as matching hatch styles in the resulting
AutoCAD files.
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Font Styles
SmartSketch default font styles are pre-mapped to their most equivalent AutoCAD
font styles (True Type Fonts (TTF)) on the Font tab of the AutoCAD Export
Options dialog box. Other fonts default to the txt.shx font deliver with Windows. If
the font is not listed in the mapping table on the font tab, it defaults to txt.shx in the
resulting AutoCAD file.

Dimension Styles
SmartSketch dimension styles are preserved as AutoCAD dimension styles in the
resulting dwg files.

Reference Files and OLE Inserts
AutoCAD dwg files that are referenced in SmartSketch are saved as AutoCAD
Xrefs in the resulting AutoCAD file. Raster reference files in SmartSketch are
saved as AutoCAD raster files in the resulting AutoCAD file. Other reference files
that are not currently supported during export to AutoCAD include .igr, .dgn, and
.dxf, files. OLE inserted objects such as .XLS, .DOC, or .BMP are not currently
supported during export to the AutoCAD file format

Multiple Sheets

Only the active sheet in a SmartSketch file is exported to an AutoCAD file.
Exporting multiple sheets from a document is not currently supported.

Data fidelity
Data fidelity is a phrase used to describe how accurately the data is preserved when
compared to its original form in the application that created it. SmartSketch
preserves the data accuracy of an AutoCAD file during export by mapping data to
its most equivalent form in AutoCAD. SmartSketch does not support exporting
data such as attribute sets that can be associated with elements in the file.

SmartSketch preserves element and document data support for the following areas:

Units
The subunits of the file being saved as a dwg file determines the model size of the
graphics in the resulting AutoCAD file
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Coordinates

SmartSketch data is automatically positioned to matching coordinate positions
when you translate to AutoCAD.

Layers
SmartSketch layer names are preserved as AutoCAD layer names, but the color
and linetype settings are not. The color and linestyle settings are applied directly to
Byentity, the resulting element In AutoCAD.

AutoCAD entity colors & linetypes are determined one of three ways on an
element:

• Byblock—a property that specifies that an entity inherit the color or linetype of
a block containing it. SmartSketch does not support the entity concept so the
Byblock properties are applied directly to the resulting element.

• Bylayer—a property that specifies that an entity inherit the color or linetype of
its associated layer. SmartSketch does not support the entity concept so the
Bylayer properties are applied directly to the resulting element.

• Byentity—occurs when colors and linetypes are directly applied to the entity
and override any Byblock or Bylayer properties. SmartSketch supports this
concept for all of its elements and preserves Byentity properties for colors and
linestyles.

The following is an entity to element map when you translate files.

SmartSketch AutoCAD

Line Line

Elli pse Circle

Arc Arc

Point Point

Connector Polyline

Linestring Polyline

Bspline Curve Polyline

Rectangle Polyline

Complex String Polyline
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Reference Xref

Text Text

Leader Leader

Dimension Dimension

Group Entity

Symbol Block

Smart Label Entities

Parametric Symbols Entities

Multi-representation
Symbol

Entities

Raster Reference Raster Reference
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 Procedures to Explore in On-line Help
• Open an AutoCAD Document

• Place AutoCAD Information in the Document

• Establish Relationships on an AutoCAD Reference File

• Create a Template to Insert an AutoCAD Document
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Planning Your Symbol
After you have determined the need for a symbol, you need to decide how you
want that symbol to behave. The goal is to create a symbol that acts the way a user
expects it to. .

When you create a symbol, it displays the following default behaviors:

• 90 degree rotation angles

• Automatic alignment with a target element or object when the symbol is placed
in a document

• Automatic association with a target element or object.

Tip  You can change these default behaviors with commands on the Symbol
Authoring Tools toolbar

Checklist for Consideration
When planning your symbol, the first item to consider is what happens when you
add text to a symbol. Do you want to add text to the shape? If so, you should
consider the position and appearance of labels, text boxes, or balloons. A Smart
Label can be associated with attributes that you define. You can also define
symbols that resize as a user adds text to the symbol.

The second item you should consider is what template will you want to use with
the symbol. The scale of the template affects how the symbol looks when it is
dragged in from the Symbol Explorer.

The next item for you to decide is what happens when you manipulate the symbol.
Should the symbol size, mirror, flip, and rotate freely? Do you want the symbol to
move with an element? You can set different options on the Define Symbol
Properties dialog box. You can create special points on a symbol to determine how
the symbol attaches to connectors, other symbols, or elements in a document.

How smart should you make the symbol? You can create symbols that have text
and parametric attributes. You can create text attributes using SmartText by
clicking the SmartText button on the Symbol Authoring Tools toolbar. You can
create parametric attributes by adding driving dimensions to the symbol and then
adding the dimensions to the Parameters tab on the Define Symbol Properties
dialog box.

Do you want users to access special programs when they drop a symbol or drag it?
You can set options for these and more on the Define Symbol Properties dialog
box.
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Do you want users to choose from a list of representations for the same symbol?
You can accomplish this by clicking the Symbol Representation button on the
Symbol Authoring Tools toolbar.

Tips for Developing Your Symbol
Developing your symbol in an orderly, thoughtful fashion saves you time in the
long run. You can consider the following suggestions:

• Make notes on what you want the symbol to do. What are your requirements?
If the symbol is to be part of a larger set, define the common requirements for
the entire set first.

• Draw a preliminary version of the symbol and format it to look the way you
want. Experiment with it. What behaviors do you want when the symbol is
rotated or scaled?

• If you want to add parametric attributes, experiment with different formulas in
the Variable Table. Create one formula at a time and test its effect on the
symbol. Keep notes as you go. You might want to copy the symbol each time
you try a new formula to keep a record of your experimentation.

• You should test the symbol for usability by allowing a coworker to play around
with the symbol. Does the symbol meet the coworker’s expectations?

After you have considered all of these items, you should recreate the symbol from
scratch. This is the best way to ensure that the symbol contains no obsolete
parameters, attributes, or other behaviors that would clutter the symbol or increase
its size.
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Using Blank Color and Fill with Symbols
Symbols are actually groups of graphic elements with defined behaviors and
properties that are saved in an .SYM document. You can enhance a symbol’s
display and performance during symbol design and creation. Incorporating a fill
with blank color into the symbol allows the symbol, when placed, to mask out
elements such as lines or connectors that intersect the symbol. This gives the
appearance that the underlying lines have been broken at the edges of the symbol.
In reality, the lines still exist beneath the symbol.

You can apply a fill to any closed boundary. Placing many fills in a document can
significantly increase the size of the document. A single fill can be used for the
symbol by filling an area that represents the outer edges of the symbol and
displaying the detailed graphic linework on top of the fill.

The blank color can be used with any graphic object besides fill, so experiment and
you might find other uses for this masking capability. .
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Controlling How Symbols Expand
You can create symbols that shrink and grow when you enter text. You can also
determine how users can resize a symbol by specifying parametric handles or scale
handles. Symbols with these types of handles are parametric symbols. You can
define parameters with the tools on the Symbol Authoring Tools toolbar. ..
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Integrating Programs with Your Symbol
You can kick off special processes from your symbol when a user performs an
particular action, such as double-clicking the symbol, dragging it, or even
modifying the symbol. The special process can be a .DLL, .OCX, or .EXE file that
you created in other programming software. You can select an action from the
Standard Actions tab on the Define Symbol Properties dialog box.

You can also specify special processes that you can execute when you select a
symbol, click the right mouse button, and then click a custom command on the
shortcut menu. The command names of the processes that you define appear at the
top of the shortcut menu. You define these processes on the Custom Actions tab of
the Define Symbol Properties dialog box.
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Controlling Display Properties
You can control display properties for symbols in various ways. You can change
the properties of various elements in the shape by applying styles or setting options
such as line weight and color on the ribbon bar. You can also determine what
handles appear on the symbol by setting options on the Define Symbol Properties
dialog box.

On this dialog box, you can also set options for how the symbol displays when a
user drags it into the document. For example, if you want the symbol to display as
separate elements, and not a unified symbol, you can click the Discrete Objects
option on the Behaviors tab of the Define Symbol Properties dialog box.
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Controlling Connectors for Symbols
Connect points allow you to determine how a connector line attaches to a symbol.
You can define and remove connect points with the Place/Edit Connect Points
button on the Symbol Authoring Tools toolbar.

You can specify the angle at which a connector attaches to a symbol. When you
attach a connector to a symbol with a connect point, the connector automatically
attaches to the point at the angle in radians that you set in the attributes of the
connect point. For example, you can place a connect point with an angle value of
1.5708 radians, or pi divided by two. Then, the connector automatically attaches to
the connect point at an angle of 1.5708 radians.

You can specify the angle by entering the value that you want in the Current
Connect Points Angles box on the Place/Edit Connect Points dialog box.
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Creating Flexible Symbols with Handles
Your symbol might need more control than users can implement by simply
selecting the symbol and dragging. You can add different types of handles to give
the user more control over the symbol.
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Scales and Symbols
The scale of a template can affect the visual size of a symbol when you drag the
symbol into a document. For example, the scale for the Architecture (metric)
template is set to 1:100 mm on the Sheet Setup dialog box. Some symbols that you
drag into documents based on that template appear small.
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Managing Text in Symbols
You can add text to symbols by creating text boxes and balloons, placing text
labels, or creating Smart Labels with Smart Text. Smart Text defines the text
attributes for the symbol.

A label with Smart Text attributes is intelligent: Smart Labels with Smart Text read
and write properties from an element or object. A label with Smart Text can
assume the attributes of an element if the attributes for the element have the same
name. Users can then edit the values of the text attributes in the Attribute Viewer.
Users cannot change the names of the attributes.

Not all labels assume the text attributes of an element or object. Some labels
contain shapes that grow automatically if you add text to the label. These are called
text-driven symbols.



Chapter 21 SmartSketch Getting Started Guide

304

 Procedures to Explore in On-line Help
• Create a Parametric Symbol

• Define a Text-Driven Symbol


